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Learning Center Package Installation Form 2315-190610

INTRODUCTION

The groov® EPIC Learning Center Package contains files, grouped into projects, that can help you learn how to 

create control programs that run on a groov EPIC processor and interact with groov I/O modules. They 

complement the groov EPIC® Training Series, our FREE online training course, which is available at 

training.opto22.com.

VERIFY VERSION COMPATIBILITY

Because the online training courses evolve along with the Opto 22 product line, it’s important to make sure 

you that the version of the Learning Center Package that you downloaded is compatible with the firmware 

installed on your Learning Center.

The Opto 22 website always provides the most recent version of the package. If you want to keep older 

versions available for your reference, save a local copy of the older versions of the package.

Version 1.3.2 of the groov EPIC Learning Center Package requires the following minimum versions of software 

and firmware:

• groov EPIC Firmware 1.3.0

• CODESYS® Development System 3.5.13, Patch 1

• Opto 22 CODESYS Library Package 1.0.0.1

• PAC Control 10.2

• PAC Display 10.2

Check the version of firmware on the groov EPIC processor mounted on your Learning Center:

1. If your groov EPIC Learning Center is not on, turn it on and log in with a user ID with system level 

privileges.

If this is the first time you turn on the groov EPIC Learning Center, you’ll need to create the first system user ID. For 

important information regarding this user ID, see “Creating the First System User ID and Finding the Hostname” 

on page 4.

2. In groov Manage, click or tap Info and Help > About.

3. In the EPIC section, if the System Version is 1.3.0-b60 or higher, your groov EPIC processor is at the correct 

level of groov EPIC Firmware. If it is lower, you’ll need to update the firmware. For instructions on updating 

the firmware, see “Updating Firmware on a groov EPIC Unit” in the groov EPIC User’s Guide (form 2267).

WORKING WITH THE groov EPIC LEARNING CENTER PACKAGE

The files in the package are for your reference and development. Here are a few ideas on how to work with the 

files:

• As you complete courses in the online training, compare your project files with the files in the package. 

This is another way to check whether the results you achieve are similar to what you may find in 

completed and functioning project files.

• If you have working knowledge and experience with the software and firmware listed in “Verify Version 

Compatibility” on page 1, you can probably skip the instructions in “Running Projects on the groov EPIC 

Processor” on page 4, which provide step-by-step instructions on installing and running the project files. 

You can install the projects on your own, then run the projects to review the programming, organization, 

and functionality featured in the projects.

https://www.opto22.com/support/resources-tools/documents/2267-groov-epic-user-s-guide
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• If you have expert knowledge with the software and firmware listed in “Verify Version Compatibility” on 

page 1, you can install the project files and modify them to help you get a jump-start on creating a Proof 

of Concept project.

• If you are familiar with PAC Control programming and want to learn more about creating IEC61131-3 

compliant programs, the I/O in the CODESYS project files have the same names as the I/O in the PAC 

Control project files. This may help you in your learning.

PROJECT DEPENDENCES AND PREREQUISITES

Review the following list to understand the dependencies between the projects included in the Learning 

Center Package, as well as any prerequisites required by a project:

• CODESYS–This project associates the devices and sensors on the Learning Center's load panel to the 

I/O channels. The project includes examples of a Ladder Diagram and Structure Text. The files for this 

project are in the CODESYS Complete folder. You also need CODESYS Development System installed on 

your computer.

• groov View–This project runs a groov View HMI for the strategy in the PAC Control Strategy project, and 

has Data Stores that work with the Node-RED project flows and the MQTT online lessons. If you want to 

run this project, you must install and run the PAC Control Strategy first. The files for this project are in the 

groov View Complete folder.

• Node-RED–The flows in the Node-RED project write to the PAC Control strategy and provide data for the 

Weather page of the groov View project. If you want to run this project, you must install and run the PAC 

Control Strategy first. The files for this project are in the Node-RED Complete folder.

You will also need to create a DarkSky account and obtain an API key. For instructions, see “Creating a 

DarkSky Account and Obtaining an API Key” on page 3.

• PAC Control Strategy–This strategy runs the logic that controls the interaction between the devices 

and sensors on the Learning Center’s load panel and the HMI (PAC Display or groov View). If you want to 

run the PAC Display Project, the groov View project, or the Node-RED project, you must install and run the 

PAC Control Strategy first. The files for this project are in the PAC Control Strategy Complete folder. You 

also need PAC Control installed on your computer.

• PAC Display Project–This project runs a PAC Display HMI for the strategy in the PAC Control Strategy 

project. If you want to run this project, you must install and run the PAC Control Strategy project first. The 

files for this project are in the PAC Display Project Complete folder. You also need PAC Display installed on 

your computer.

UNCOMPRESSING THE GROOV EPIC LEARNING CENTER PACKAGE

The Learning Center Package is a compressed file. Uncompress the file to your computer, making note of the 

path where you uncompressed the files. You will need this path information when you install and run the 

projects.

BACKING UP PREVIOUS WORK

If you already worked with your groov EPIC Learning Center and want to save any work you’ve done, review 

the instructions in “Backing up Your groov EPIC Processor” in the groov EPIC User’s Guide (form 2267) to create 

a back up of your work.

https://www.opto22.com/support/resources-tools/documents/2267-groov-epic-user-s-guide
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SETTING UP YOUR COMPUTER

If you want to run the PAC Control, PAC Display, or CODESYS projects, you’ll need to install the corresponding 

software on your computer. The PAC Control and PAC Display software is available for download from the 

Opto 22 website (www.opto22.com). The CODESYS software is available from the CODESYS Store 

(store.codesys.com).

When you received your groov EPIC Learning Center, it included a printed document called groov EPIC 

Learning Center Setup (form 2311). The back page of that document included instructions on installing:

• PAC Project, which installs PAC Control and PAC Display.

• CODESYS Development System and the Opto 22 Library Package for CODESYS Development System.

Review the installation instructions in that document. If you can’t find that document, you can also follow the 

instructions in the following online resources:

• PAC Project Basic download page on www.opto22.com. The PAC Project Basic software package installs 

PAC Control, PAC Display, and several other software applications. Review the description, particularly 

where it describes how you indicate which applications you want to install.

• To install CODESYS Development System and the Opto 22 Library Package for CODESYS Development 

System, go through the online course Installing the Opto 22 Library Package.

• Another resource for instructions on installing CODESYS Development System and the Opto 22 Library Package for 

CODESYS Development System is the groov EPIC User’s Guide (form 2267). Follow the instructions in the first 

three sections of “Chapter 8: Configure CODESYS and groov EPIC for IEC61131-3”:

– Obtaining Your CODESYS Activation Key Certificate and Ticket ID

– Downloading and Installing CODESYS Development System

– Adding the Opto 22 Library Package to CODESYS Development System

Note: Typically, if you download the most recent versions of this software from their respective websites, they can run 

any version of the groov EPIC Learning Center Package. However, if you already have a version of these software 

products installed on your computer, find the version number of the installed software and compare it to the 

compatibility table in “Version History” on page 8 to make sure the software can run the projects.

CREATING A DARKSKY ACCOUNT AND OBTAINING AN API KEY

If you want to run the Node-RED project, you need to create a DarkSky account and obtain an API key, which 

they call a secret key.

1. Go to the DarkSky website (https://darksky.net/dev).

2. Follow the instructions on the website to sign up/register for an account. After you confirm your email 

address and login with your new account, the DarkSky website shows you your secret key (blurred in the 

following image):

https://www.opto22.com/support/resources-tools/documents/2267-groov-epic-user-s-guide
https://www.opto22.com/products/pacprojectbas
https://www.opto22.com
https://training.opto22.com/getting-ready-to-use-the-codesys/293769
https://darksky.net/dev
https://store.codesys.com/
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3. Highlight the secret key and press CTRL+C to copy the text to the computer’s clipboard.

4. Open your favorite text editor and paste the secret key into the editor. Save it with a file name like 

DarkSky_key.txt. You may want to save the file in a secure location.

When you are preparing the Node-RED project, you’ll need the DarkSky secret key when you get to “Configure 

Prerequisite Nodes” on page 6.

CREATING THE FIRST SYSTEM USER ID AND FINDING THE HOSTNAME

In any of the following situations, you will need to create a new system user ID:

• Turning on a new groov EPIC Learning Center for the first time.

• Turning on a groov EPIC Learning Center after installing a firmware update.

• Resetting a groov EPIC processor to factory defaults.

Create this user ID with a password that follows strong security recommendations. This user ID is the first 

administrator level user for your Learning Center. Remember it! groov EPIC does not provide a way to recover 

a lost password or username.

If you did not note the hostname when you turned on the Learning Center for the first time, you can find it on 

the Network page of groov Manage (Home > System > Network).

RUNNING PROJECTS ON THE groov EPIC PROCESSOR

The instructions in this section take you step-by-step through installing and running each project.

Running the PAC Control Project

Make sure you have PAC Control installed. (See “Setting Up Your Computer” on page 3.)

1. Start PAC Control.

2. Load the strategy.

a. In PAC Control, click File > Open Strategy.

b. Navigate to the folder where you uncompressed the Learning Center Package and open the PAC 

Control Strategy Complete folder.

c. Select Cstore.idb and click Open.

3. Set the Control Engine to the groov EPIC processor on your Learning Center.

a. Expand the Control Engines folder in the Cstore window.

b. Double-click EpicLC.

c. In the Configure Control Engines window, click Add.

d. Find your groov EPIC Learning Center (usually epic-lc###, where ### is a 3-digit number) in the 

Select Control Engine window and select it. Click OK.

e. Click Set Active in the Configure Control Engines window.

f. Click OK to close the Configure Control Engines window.

4. Save changes and run the strategy.

a. Click File > Save Strategy.

b. Click Mode > Debug. In the Download Warning window, click Yes to acknowledge the warnings or 

notifications and proceed to download the strategy to the processor.

c. Click Run > Debug to run the strategy.
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Running the PAC Display Project

Make sure you have PAC Display installed. (See “Setting Up Your Computer” on page 3.)

1. Start PAC Display Configurator.

2. Load the PAC Display project and set the control engine to the groov EPIC processor on your groov EPIC 

Learning Center.

a. In PAC Display Configurator, click File > Open Project.

b. Navigate to the folder where you uncompressed the Learning Center Package and open the 

PAC Display Project Complete folder.

c. Select Learning_Center.UUI and click Open.

d. In the Cannot find the strategy file window, click OK.

e. In the Control Engines window, select EpicLC, then click Replace.

f. In the Control Engine Properties window, click Browse.

g. In the Select Control Engine window, select your groov EPIC Learning Center (usually epic-lc###, 

where ### is a 3-digit number) in the Configured Control Engines list, then click OK.

h. Click OK to close the Control Engine Properties window.

i. Click OK to close the Control Engines window.

3. Save the project and run it.

a. Click File > Save Project and Load Runtime.

b. The Event Log Viewer displays a message indicating the date and time that the PAC Display runtime 

was started, as well as the version. Click OK to close the window.

The PAC Display project is running. You can click through the interface to interact with the screen, as well as 

interact with the load panel to observe changes on the PAC Display HMI.

Running the groov View Project

1. Connect to your groov EPIC processor from a browser.

a. Open a browser and type in the hostname of your Learning Center in the URL bar: 

https://<hostname>

b. Log in with the system user ID and password you created in “Creating the First System User ID and 

Finding the Hostname” on page 4.

2. Start groov View and load the groov View project.

a. In the groov Manage Home page, click groov View.

b. Click the menu button ( ), then select Switch to Build mode.

c. Click File > Restore Project from Computer.

d. In the Restore Project window, click Browse.

e. Navigate to the folder where you uncompressed the Learning Center Package and open the 

groov View Complete folder.

f. Select groov-View_Complete.tar.gz and then click Open.

g. In the Restore Project window, type in opto for both the user name and password.

h. Click Restore.

i. Click OK to restore the project window.

3. Set the Controller Address to the groov EPIC processor on your Learning Center.

a. From the groov Build menu, select Configure > Devices and Tags.

b. Highlight CStore, and click Edit Device.

c. Change the Controller Address to your groov EPIC Learning center address (usually epic-lc###, 

where ### is a 3-digit number), click Edit Device, then click Close.
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4. Click File > Save All Changes and Switch to groov View.

The groov View project is now running. You can click through the interface to interact with the screen, as well 

as interact with the load panel to observe changes on the groov View HMI.

Running the Node-RED Project

Before you start, make sure you have your DarkSky secret key readily available.

Connect to your groov EPIC processor from a browser

1. Open a browser and type in the hostname of your Learning Center in the URL bar: 

https://<hostname>

2. Log in with the system user ID and password you created in “Creating the First System User ID and 

Finding the Hostname” on page 4.

Add Prerequisite Nodes

1. From the groov Manage Home page, click Node-RED > Open Node-RED Editor.

2. Click the menu button ( ), then Manage Palette.

3. Click the Install tab.

4. Type Opto 22 in the search field.

a. Find the node-red-contrib-groov node, then click Install. In the message box, click Install. Wait for 

the install to finish before going to the next step.

b. For the node-red-contrib-pac node, click Install. In the message box, click Install. Wait for the install 

to finish before going to the next step.

c. In the search field, replace Opto 22 with mssql.

d. For the node-red-contrib-mssql node, click Install. In the message box, click Install. Wait for the 

install to finish before going to the next step

e. Close the Node-RED Editor tab on your browser.

Load the Node-RED project

1. Switch back to the groov Manage tab on your browser, which should still be showing the Node-RED 

page. Click Project Management.

2. Click Upload Project.

3. Navigate to the folder where you uncompressed the Learning Center Package and open the 

Node-RED Complete folder.

4. Select the node-red.project.COMPLETE v1.3.zip file and click Open. groov Manage displays 

a message that it is uploading the project. When the upload is done, click Restart Node-RED.

5. After a few moments, groov Manage displays a message that it restarted Node-RED. Click Close.

Configure Prerequisite Nodes

You’ll configure the nodes you installed in “Add Prerequisite Nodes” on page 6 so that they refer to the groov 

EPIC processor on your Learning Center and to add you DarkSky secret key.

1. Go to the groov Manage Home page, then click Accounts.

2. Click on the user ID that will run the Node-RED project. This is typically the first user ID you created when 

you turn on the Learning Center for the first time. (See “Creating the First System User ID and Finding the 

Hostname” on page 4.)

3. In the API Key section, select the text in the API Key field and press CTRL+C to copy it to the computer 

clipboard.

4. Click Cancel, then Home.
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5. Click Node-RED, then Open Node-RED Editor.

6. For the temperature, fuelLevel, and SlushyStartButton nodes, repeat the following steps:

a. Double-click the node.

b. Click the modify button next to the Device field.

c. In the Address field, type in the hostname of the groov EPIC processor mounted on your Learning 

Center.

d. In the API Key Value field, paste the API key you copied from step 3 (above).

e. Click Update.

f. Click Done.

7. For the groov write node:

a. Double-click the node.

b. Click the modify button next to the Data Store field.

c. Click the modify button next to the Groov Project field.

d. In the API Key Value field, paste the API key you copied from step 3 (above).

e. Click Update.

f. Click Update.

g. Click Done.

8. For the DarkSky node:

a. Double click the node.

b. Click in the URL field and move the cursor to the right until you see 

<Your_DarkSky_API_Key>.

c. Highlight <Your_DarkSky_API_key> and replace it with the DarkSky secret key you saved. 

(See “Creating a DarkSky Account and Obtaining an API Key” on page 3.)

d. Click Done.

Deploy the flow

Click Deploy in the upper-right corner of the Node-RED Editor. After a few moments, you may begin to see 

some activity on your screen. You can start interacting with the nodes on the flow and switching to the other 

tabs (for example, the Debug Messages tab) to view notifications.

Running the CODESYS Project

Make sure you have CODESYS Development System and Opto 22 CODESYS Library Package installed. (See 

“Setting Up Your Computer” on page 3.)

1. From the groov Manage Home page, select Controller > CODESYS Controller, then click Enable to start 

the CODESYS control engine.

2. Load the CStore_CODESYS v1.0.project to CODESYS Development System.

a. Start CODESYS Development System.

b. Click File > Open.

c. Navigate to the folder where you uncompressed the Learning Center Package and open the 

CODESYS Complete folder.

d. Select CStore_CODESYS v1.0.project and click Open.

CODESYS Development system checks whether the version of the Opto 22 Library Package installed 

in CODESYS Development System matches the level that was used to create the 

CStore_CODESYS v1.0.project. If they do not match, CODESYS Development System displays the 
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Project Environment window, where you can indicate whether you want CODESYS Development 

System to upgrade the library in the current project to the level installed:

Double-click Do not update in the Action column to view a list of actions to take. Select Upgrade to 

1.0.0.0, then click OK.

3. Add your Learning Center’s groov EPIC processor to the project, then download and run the project.

a. Double-click Device in the Devices view, then Scan Network.

b. Select the groov EPIC processor mounted on your Learning Center, usually epic-lc###, where 

### is a 3-digit number. Click OK.

c. Click File > Save Project.

d. Click Build > Build.

e. Click Online > Login.

If you get a warning about the current application replace an existing application that’s running on 

the groov EPIC processor, click Yes.

f. Click Debug > Start.

Now that the CODESYS application running, you can do things like set breakpoints, cycle through ladder 

diagram, or toggle channels to see how the lights change on the Learning Center’s load panel.

VERSION HISTORY

Because the Opto 22 product line and online training are always evolving, it’s possible that the Learning 

Center Package you download or saved is incompatible with the version of firmware installed on the 

processor mounted on your Learning Center, or the software running on your computer. Review the following 

table to determine compatibility:

The version of the Opto 22 Library Package 
for CODESYS Development System currently 
installed on CODESYS Development System.

The version of the Opto 22 Library Package 
for CODESYS Development System that 
Opto 22 used to create the CODESYS 
project.

If you have this version of the 
Learning Center Package...

...it works with this version of firmware and software:

1.0.0 or higher

• groov EPIC firmware 1.3.0 or higher
• CODESYS Development System 3.5.13 Patch 1
• Opto 22 CODESYS Library Package 1.0.0.0 or higher
• PAC Control 10.2
• PAC Display 10.2
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1.3.2 or higher

• groov EPIC firmware 1.3.0 or higher
• CODESYS Development System 3.5.13 Patch 1
• Opto 22 CODESYS Library Package 1.0.0.1 or higher
• PAC Control 10.2
• PAC Display 10.2

If you have this version of the 
Learning Center Package...

...it works with this version of firmware and software:


